Guest Manager is in a degraded state

Incident Report for Yelp Developer APIs and Services

Resolved

This incident has been resolved.
Posted Sep 19, 2023 - 08:29 PDT

Monitoring

As our downstream provider fixed the technical issues, Yelp Reservation web interface is up and functioning again (as well as all of the other systems). Currently we are monitoring our systems for any other potential errors.
Posted Sep 19, 2023 - 07:54 PDT

Update

Errors are continuing at a low rate. Engineering is monitoring while we wait for our downstream provider to fix the issue.
Next update tomorrow morning, or sooner if things change
Posted Sep 18, 2023 - 16:05 PDT

Identified

We are continuing to investigate possible mitigation strategies while our service provider addresses the root cause.
Posted Sep 18, 2023 - 14:55 PDT

Update

We are continuing to investigate the issue. Next update in 30 minutes.
Posted Sep 18, 2023 - 14:00 PDT

Investigating

The Yelp Reservations web interface is currently down, and the Yelp Reservation ipad apps may be experiencing issues.
Posted Sep 18, 2023 - 13:10 PDT

Monitoring

Engineering has implemented a mitigation and Guest Manager has recovered.

We are monitoring, and continuing to investigate and confirm the cause of the issue.

Next update in 30 minutes.
Posted Sep 18, 2023 - 12:39 PDT

Investigating

Guest Manager is currently serving errors to a low percentage of requests to the GM app (ie restaurant users), as well as higher than normal latency to both restaurants and diners.

Engineering is investigating. Next update in 30 minutes.
Posted Sep 18, 2023 - 12:15 PDT
This incident affected: Yelp for Restaurants (Yelp Reservation, Yelp Guest Manager).